mlreg error zero elements in diagonal

Questions about GenABEL (aka *ABEL) suite of packages
Forum rules
Please remember not to post any sensitive data on this public forum.
The first few posts of newly registered users will be moderated in order to filter out any spammers.

When get a solution to the problem you posted, please change the topic name (e.g. from "how to ..." to "[SOLVED] how to ..."). This will make it easier for the community to follow the posts yet to be attended.
Annemieke
Posts: 2
Joined: Wed Apr 08, 2015 2:22 pm

mlreg error zero elements in diagonal

Postby Annemieke » Mon Oct 19, 2015 12:14 pm

Hi all,
I would like to do logistic regression analysis in GenABEL for about 300 cases and 5000 controls for about 200,000 SNPs, for which I use the following command;

logreg_all<-mlreg(outcome~sex, data_set, gtmode = "additive", trait.type = "binomial", propPs = 1)

However, I get an error:
#Error in mlreg(outcome ~ sex, data_set, gtmode = "additive", trait.type = "binomial", :
# invert: zero elements in diagonal

My outcome is 1/0, I would like to test the additive effect of the SNPs.
I already selected SNPs with MAF (minor allele frequency (summary$Q.2)) >0 and high call rate PER outcome group (or is monomorph allowed in one of the two groups?)

The error does not occur when I make a selection of SNPs for which also the frequency of heterozygotes and of homozygotes for the minor allele is larger than 0 in both outcome groups (summary_cases$P.12>0 & summary_cases$P.22>0 & summary_controls$P.12>0 summary_controls$P.22>0).
However, I don't want to exclude these SNPs, and it seems that my SNPs are tested as a categorial variable (where you can not miss a category), instead of as a integer (0,1 and 2)?

Can anyone help me?
Many thanks in advance!

Return to “GenABEL”

Who is online

Users browsing this forum: No registered users and 3 guests