impute2mach error

Questions about GenABEL (aka *ABEL) suite of packages
Forum rules
Please remember not to post any sensitive data on this public forum.
The first few posts of newly registered users will be moderated in order to filter out any spammers.

When get a solution to the problem you posted, please change the topic name (e.g. from "how to ..." to "[SOLVED] how to ..."). This will make it easier for the community to follow the posts yet to be attended.
lckarssen
Site Admin
Site Admin
Posts: 322
Joined: Tue Jan 04, 2011 3:04 pm
Location: Utrecht, The Netherlands

Re: impute2mach error

Postby lckarssen » Thu Jan 14, 2016 1:24 pm

That's great to hear! Thank you for confirming this. I will incorporate this fix and try to get a new version of the package out as soon as I have time.
-------
Lennart Karssen
PolyOmica
The Netherlands
-------

shirleydaidai
Posts: 4
Joined: Tue Feb 14, 2017 7:00 am

Re: impute2mach error

Postby shirleydaidai » Wed Feb 22, 2017 9:22 am

Hello,
I came across the same error message after source "impute2databel.R". Is there some update info available?

Code: Select all

> library('GenABEL')
Loading required package: MASS
Loading required package: GenABEL.data
> library(DatABEL)
DatABEL v.0.9-6 loaded

> source("impute2databel.R")
> impute2mach("chr22.phased.chunk8.impute2","chr22.phased.chunk8.impute2_info","chr22.phased.sample","MachFormat", maketextdosefile=TRUE, chromosome =22, order_geno_snp_a0_a1 = c(2, 4:5),skip_geno = 0,order_info_snp_pos_freq1_info_qual_type = c(2:7),skip_info = 1, allow_duplicated_names = FALSE)
Options in effect:
         --infile    = chr22.phased.chunk8.impute2
         --outfile   = ./tmp485157
         --skiprows  = OFF
         --skipcols  = 5
         --cnrow     = OFF
         --rncol     = ON, using column 2 of 'chr22.phased.chunk8.impute2'
         --transpose = ON
         --Rmatrix   = OFF
         --nanString = NA
Number of lines in source file is 15417
Number of words in source file is 665
skiprows = 0
cnrow = 0
skipcols = 5
rncol = 2
Rmatrix = 0
numWords = 665
Creating file with numRows = 15417
Creating file with numColumns = 660
text2fvf finished.
Error in .Call("iterator", tmp_fv@data, as.integer(0), as.integer(0),  :
  "iterator" not resolved from current namespace (GenABEL)



Code: Select all

> sessionInfo()
R version 3.2.2 (2015-08-14)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 15.10

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] DatABEL_0.9-6      GenABEL_1.8-0      GenABEL.data_1.0.0 MASS_7.3-45


Return to “GenABEL”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests