coding of "half deletions"

Questions about GenABEL (aka *ABEL) suite of packages
Forum rules
Please remember not to post any sensitive data on this public forum.
The first few posts of newly registered users will be moderated in order to filter out any spammers.

When get a solution to the problem you posted, please change the topic name (e.g. from "how to ..." to "[SOLVED] how to ..."). This will make it easier for the community to follow the posts yet to be attended.
Posts: 1
Joined: Wed Jun 29, 2016 11:28 am

coding of "half deletions"

Postby CRW » Wed Jun 29, 2016 11:34 am


I am trying to load canola hybrid SNP data in GenABEL. Since I created the hybrids in silico from the Illumina genotyping files of the parents, some hybrids can contain "half deletions" (e.g. A-).
According to the GenABEL manual

"Accepted allele codes: 1/2, A/B, A/T, A/G, A/C, T/G, T/C, G/C, A/-, T/-, G/-, C/-. Here, "-" stands of a deletion. Missing data can be coded as "–" or "00". Make sure that the coding for missing is "00" if you use one of the codings A/-, T/-, G/-, C/-"

I tried to code my half deletions like this (in this short testfile below):

ID chrom snp_pos G1 G2 G3
M1 1 36516 T- TG TG
M2 1 50056 AT TA TA

which gives me the following error:
"error in in convert.snp.illumina(inf = "Genabel_CoreSet_test2.pop", out = "Genabel_CoreSet_test2.raw", :
illegal genotype (half missing) SNP 'M1' file 'Genabel_CoreSet_test2.pop' line 0 !"

I tried several other codings for the matrix, including T/-, -T, -/T, T0, but none of them is able to handle my "half deletions". However, it works as soon as I replace the first SNP genotype by TT, so the rest of my file seems to be correct.

Does anyone know how to solve this problem?

Many thanks in advance!

Return to “GenABEL”

Who is online

Users browsing this forum: No registered users and 2 guests